Saturday 1 September 2012

Simple MPLS Traffic-engineering



Tunnel 1
-destination 2.2.2.2
-primary path = R1>R4>R2
-secondary path = dynamic
----------------------------------------------------------------------------------------------------------------------------
R1 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng path-option 10 explicit name R1-R4-R2
 tunnel mpls traffic-eng path-option 20 dynamic
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip ospf cost 10
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.14.1 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
 network 192.168.14.1 0.0.0.0 area 0
!
ip explicit-path name R1-R4-R2 enable

 next-address 192.168.14.4
 next-address 192.168.24.2

R2 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 192.168.24.2 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0
 network 192.168.24.2 0.0.0.0 area 0

R3 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.34.3 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 network 192.168.34.3 0.0.0.0 area 0

R4 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.14.4 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.34.4 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 192.168.24.4 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.14.4 0.0.0.0 area 0
 network 192.168.24.4 0.0.0.0 area 0
 network 192.168.34.4 0.0.0.0 area 0

Verification

R1#show mpls traffic-eng tunnels tunnel 1

Name: R1_t1                               (Tunnel1) Destination: 2.2.2.2
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected

    path option 10, type explicit R1-R4-R2 (Basis for Setup, path weight 2)
    path option 20, type dynamic

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 0        bw-based
    auto-bw: disabled

  InLabel  :  -
  OutLabel : FastEthernet0/1, 19
  RSVP Signalling Info:
       Src 1.1.1.1, Dst 2.2.2.2, Tun_Id 1, Tun_Instance 78
    RSVP Path Info:
      My Address: 192.168.14.1
      Explicit Route: 192.168.14.4 192.168.24.4 192.168.24.2 2.2.2.2
      Record Route:  NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record Route:  NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  Shortest Unconstrained Path Info:
    Path Weight: 2 (TE)
    Explicit Route: 192.168.14.1 192.168.14.4 192.168.24.4 192.168.24.2
                    2.2.2.2

  History:
    Tunnel:
      Time since created: 22 minutes, 52 seconds
      Time since path change: 5 minutes, 48 seconds
    Current LSP:
      Uptime: 5 minutes, 48 seconds
    Prior LSP:
      ID: path option 10 [77]
      Removal Trigger: tunnel shutdown



No comments:

Post a Comment