Saturday 8 September 2012

Mulitcasting in PIM BSR Enviroment


R2 is the bsr router.
R3 and R4 are the RP candidates routers.
R7 will be acting like a multicast receiver and joining the groups 235.0.0.1 and 235.0.0.2
R5 or R6 will send multicast feeds to those groups.

R1 Config

ip multicast-routing
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet1/1
 ip address 192.168.14.1 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet2/0
 ip address 192.168.15.1 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
router ospf 1
 log-adjacency-changes

R2 Config

ip multicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet1/1
 ip address 192.168.23.2 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet2/0
 ip address 192.168.24.2 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
router ospf 1
 log-adjacency-changes
!
ip pim bsr-candidate Loopback0
R3 Config

ip multicast-routing
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet1/0
 ip address 192.168.23.3 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
 speed auto
 duplex auto
!
interface FastEthernet1/1
 ip address 192.168.34.3 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet2/0
 ip address 192.168.36.3 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
router ospf 1
 log-adjacency-changes
!
ip pim rp-candidate Loopback0

R4 Config

ip multicast-routing
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet1/0
 ip address 192.168.14.4 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet1/1
 ip address 192.168.24.4 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet2/0
 ip address 192.168.34.4 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface FastEthernet2/1
 ip address 192.168.47.4 255.255.255.0
 ip pim sparse-mode
 ip ospf 1 area 0
!
router ospf 1
 log-adjacency-changes
!
ip pim rp-candidate Loopback0

R5 Config

interface FastEthernet0/0
 ip address 192.168.15.5 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.15.1

R6 Config

interface FastEthernet0/0
 ip address 192.168.36.6 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.36.3

R7 Config

interface FastEthernet0/0
 ip address 192.168.47.7 255.255.255.0
 ip igmp join-group 235.0.0.1
 ip igmp join-group 235.0.0.2
!
ip route 0.0.0.0 0.0.0.0 192.168.47.4

Verification

R1#show ip pim bsr-router
PIMv2 Bootstrap information
  BSR address: 2.2.2.2 (?)
  Uptime:      02:50:51, BSR Priority: 0, Hash mask length: 0
  Expires:     00:01:46

R1#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 4.4.4.4 (?), v2
    Info source: 2.2.2.2 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:08:43, expires: 00:02:14
  RP 3.3.3.3 (?), v2
    Info source: 2.2.2.2 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 02:39:36, expires: 00:02:15

-Since R7(multicast receiver) is requesting the multicast feeds for the 235.0.0.1 and 235.0.0.2, R4 has the *, group mroute entry for those groups.

R4#show ip mroute

(*, 235.0.0.1), 02:31:34/00:02:39, RP 4.4.4.4, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet2/1, Forward/Sparse, 02:31:34/00:02:39

(*, 235.0.0.3), 00:23:32/00:02:39, RP 4.4.4.4, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:07:05/00:02:39

(*, 224.0.1.40), 02:32:22/00:02:16, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:32:22/00:02:16

-When R5 starts to send traffic to 235.0.0.1,

R5#ping 235.0.0.1 repeat 100
Reply to request 0 from 192.168.47.7, 200 ms
Reply to request 1 from 192.168.47.7, 104 ms
Reply to request 1 from 192.168.47.7, 128 ms

-Now we see R4 and R1 updates it mroute table. Both routers are using 4.4.4.4(R4 Loopback 0) as the RP address.

R4#show ip mroute

(*, 235.0.0.1), 02:34:53/stopped, RP 4.4.4.4, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet2/1, Forward/Sparse, 02:34:53/00:02:14

(192.168.15.5, 235.0.0.1), 00:00:12/00:02:50, flags: T
  Incoming interface: FastEthernet1/0, RPF nbr 192.168.14.1
  Outgoing interface list:
    FastEthernet2/1, Forward/Sparse, 00:00:12/00:02:47

(*, 224.0.1.40), 02:35:41/00:01:58, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:35:41/00:01:58

R1#show ip mroute

(*, 235.0.0.1), 00:00:45/stopped, RP 4.4.4.4, flags: SPF
  Incoming interface: FastEthernet1/1, RPF nbr 192.168.14.4
  Outgoing interface list: Null

(192.168.15.5, 235.0.0.1), 00:00:45/00:02:48, flags: FT
  Incoming interface: FastEthernet2/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet1/1, Forward/Sparse, 00:00:45/00:02:46

(*, 224.0.1.40), 00:23:51/00:02:43, RP 0.0.0.0, flags: DPL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null




No comments:

Post a Comment