Saturday 1 September 2012

Traffic-engineering Routing Loops with Static Routes



mpls traffic-eng tunnels
mpls traffic-eng reoptimize timers frequency 30
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 2.2.2.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng path-option 10 explicit name R1-R4-R2
 tunnel mpls traffic-eng path-option 20 dynamic
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.14.1 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 192.168.15.1 255.255.255.0
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
 network 192.168.14.1 0.0.0.0 area 0
 network 192.168.15.1 0.0.0.0 area 0
!
ip explicit-path name R1-R4-R2 enable
 index 2 next-address 192.168.14.4
 index 4 next-address 192.168.24.2

R2 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 192.168.24.2 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0
 network 192.168.24.2 0.0.0.0 area 0

R3 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
 ip address 3.3.3.33 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.34.3 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 192.168.35.3 255.255.255.0
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 3.3.3.3 0.0.0.0 area 0
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 network 192.168.34.3 0.0.0.0 area 0
 network 192.168.35.3 0.0.0.0 area 0

R4 Config

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.14.4 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet0/1
 ip address 192.168.34.4 255.255.255.0
 ip ospf cost 10
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/0
 ip address 192.168.24.4 255.255.255.0
 ip ospf cost 1
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.14.4 0.0.0.0 area 0
 network 192.168.24.4 0.0.0.0 area 0
 network 192.168.34.4 0.0.0.0 area 0

R5 Config

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.15.5 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.35.5 255.255.255.0
!
router ospf 1
 network 5.5.5.5 0.0.0.0 area 0
 network 192.168.15.5 0.0.0.0 area 0
 network 192.168.35.5 0.0.0.0 area 0

-As per the above config, we have tunnel 1 on R1 terminating at R2.
But we are not using the tunnel forwarding down the traffic.
In this lab, our concerned is only 3.3.3.3/32 and 3.3.3.33/32.

R1#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 192.168.12.2, 00:01:35, FastEthernet0/0
     3.0.0.0/32 is subnetted, 2 subnets
O       3.3.3.3 [110/3] via 192.168.15.5, 00:01:35, FastEthernet1/0
                [110/3] via 192.168.12.2, 00:01:35, FastEthernet0/0
O       3.3.3.33 [110/3] via 192.168.15.5, 00:01:35, FastEthernet1/0
                 [110/3] via 192.168.12.2, 00:01:35, FastEthernet0/0

     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/2] via 192.168.14.4, 00:01:35, FastEthernet0/1
O    192.168.24.0/24 [110/2] via 192.168.14.4, 00:01:36, FastEthernet0/1
                     [110/2] via 192.168.12.2, 00:01:36, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
O       5.5.5.5 [110/2] via 192.168.15.5, 00:01:35, FastEthernet1/0
O    192.168.23.0/24 [110/2] via 192.168.12.2, 00:01:36, FastEthernet0/0
O    192.168.34.0/24 [110/3] via 192.168.15.5, 00:01:36, FastEthernet1/0
                     [110/3] via 192.168.12.2, 00:01:36, FastEthernet0/0
O    192.168.35.0/24 [110/2] via 192.168.15.5, 00:01:37, FastEthernet1/0

-If for some reason we need to forwarding down the traffic only to 3.3.3.3/32 through tunnel 1, so we need to add the static route to 3.3.3.3/32 point to tunnel 1.

R1#show run | in ip route
ip route 3.3.3.3 255.255.255.255 Tunnel1

R1#show ip route static
S       3.3.3.3 is directly connected, Tunnel1

R1#traceroute 3.3.3.3
  1 192.168.14.4 [MPLS: Label 20 Exp 0] 28 msec 40 msec 12 msec
  2 192.168.24.2 20 msec 20 msec 8 msec
  3 192.168.23.3 28 msec *  28 msec

-Forwarding to 3.3.3.33/32 is now load-balancing between R2 and R5.

R1#traceroute 3.3.3.33
  1 192.168.15.5 28 msec
    192.168.12.2 [MPLS: Label 24 Exp 0] 12 msec
    192.168.15.5 36 msec
  2 192.168.23.3 20 msec
    192.168.35.3 40 msec *


Note:  Before proceeding to read the latter part, think a while what will happen if the link between R2 and R3 failed. And the topology will become shown below.


-The traffic to 3.3.3.3/32 will endlessly loop between R1,R4, and R2 until the packet ttl expired.
But forwarding to 3.3.3.33 will still be taking the path R1>R5>R3

R1#traceroute 3.3.3.3

  1 192.168.14.4 [MPLS: Label 20 Exp 0] 48 msec 36 msec 28 msec
  2 192.168.24.2 24 msec 24 msec 32 msec
  3 192.168.12.1 [MPLS: Label 21 Exp 0] 56 msec 56 msec 72 msec
  4 192.168.14.4 [MPLS: Label 20 Exp 0] 64 msec 64 msec 56 msec
  5 192.168.24.2 60 msec 60 msec 64 msec
  6 192.168.12.1 [MPLS: Label 21 Exp 0] 100 msec 92 msec 112 msec
  7 192.168.14.4 [MPLS: Label 20 Exp 0] 128 msec 132 msec 108 msec
  8 192.168.24.2 88 msec 96 msec 92 msec
  9 192.168.12.1 [MPLS: Label 21 Exp 0] 108 msec 124 msec 132 msec
 10 192.168.14.4 [MPLS: Label 20 Exp 0] 116 msec 120 msec 136 msec
 11 192.168.24.2 128 msec 116 msec 108 msec
 12 192.168.12.1 [MPLS: Label 21 Exp 0] 100 msec 140 msec

R1#ping 3.3.3.3
.....
Success rate is 0 percent (0/5)

R1#ping 3.3.3.33
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/26/32 ms

R1#traceroute 3.3.3.33
  1 192.168.15.5 48 msec 4 msec 8 msec
  2 192.168.35.3 16 msec *  40 msec

No comments:

Post a Comment