Thursday 13 September 2012

Inter-AS MPLS VPN Option 2C Section(Through AToM AS2 Link)


By this time, R9 and R11 have a direct layer 2 connection through AS2.
AS3 of R8 and AS4 of R10 will peer bgp vpnv4 session.
In order to do so, we need TCP connection and label switch path(R8>R9>R11>R10) between the loopback networks of R8 and R10.
Between R9 and R11, bgp will be used to map the labels.

R8 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.89.8 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.128.8 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.138.8 255.255.255.0
!
router ospf 1

 network 8.8.8.8 0.0.0.0 area 0
 network 192.168.89.8 0.0.0.0 area 0
!
router bgp 3
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.10.10.10 remote-as 4
 neighbor 10.10.10.10 ebgp-multihop 4
 neighbor 10.10.10.10 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.10.10.10 activate
  neighbor 10.10.10.10 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 13.13.13.13 255.255.255.255 192.168.138.13
!

mpls ldp router-id Loopback0 force


R9 Config

interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.119.9 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.89.9 255.255.255.0
 mpls ip
!
router ospf 1

 redistribute bgp 3 subnets route-map AS4-LOOPBACKS
 network 9.9.9.9 0.0.0.0 area 0
 network 192.168.89.9 0.0.0.0 area 0
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map AS3-LOOPBACKS
 neighbor 192.168.119.11 remote-as 4
 neighbor 192.168.119.11 send-label
 no auto-summary
!
ip prefix-list AS3-LOOPBACKS seq 5 permit 8.8.8.8/32
!
ip prefix-list AS4-LOOPBACKS seq 5 permit 10.10.10.10/32
!
route-map AS3-LOOPBACKS permit 10
 match ip address prefix-list AS3-LOOPBACKS
!
route-map AS4-LOOPBACKS permit 10
 match ip address prefix-list AS4-LOOPBACKS
!

mpls ldp router-id Loopback0 force

R10 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.110.10 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.112.10 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.114.10 255.255.255.0
!
router ospf 1

 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.110.10 0.0.0.0 area 0
!
router bgp 4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 8.8.8.8 remote-as 3
 neighbor 8.8.8.8 ebgp-multihop 4
 neighbor 8.8.8.8 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 14.14.14.14 255.255.255.255 192.168.114.14
!

mpls ldp router-id Loopback0 force

R11 Config

interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.119.11 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.110.11 255.255.255.0
 mpls ip
!
router ospf 1

 redistribute bgp 4 subnets route-map AS3LOOPBACKS
 network 11.11.11.11 0.0.0.0 area 0
 network 192.168.110.11 0.0.0.0 area 0
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map AS4LOOPBACKS
 neighbor 192.168.119.9 remote-as 3
 neighbor 192.168.119.9 send-label
 no auto-summary
!
ip prefix-list AS3LOOPBACKS seq 5 permit 8.8.8.8/32
!
ip prefix-list AS4LOOPBACKS seq 5 permit 10.10.10.10/32
!
route-map AS4LOOPBACKS permit 10
 match ip address prefix-list AS4LOOPBACKS
!
route-map AS3LOOPBACKS permit 10
 match ip address prefix-list AS3LOOPBACKS
!

mpls ldp router-id Loopback0 force

R13 Config

interface Loopback0
 ip address 13.13.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.138.13 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.138.8

R14 Config

interface Loopback0
 ip address 14.14.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.114.14 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.114.10

 Verification

R8#ping 10.10.10.10 source loopback 0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 224/292/344 ms

R8#traceroute 10.10.10.10 source loopback 0
  1 192.168.89.9 [MPLS: Label 18 Exp 0] 344 msec 192 msec 232 msec
  2 192.168.119.11 [MPLS: Label 16 Exp 0] 292 msec 228 msec 320 msec
  3 192.168.110.10 320 msec *  468 msec

R8#show mpls forwarding-table
17         18         10.10.10.10/32   0             Fa1/0      192.168.89.9

R9#show mpls forwarding-table
18     16          10.10.10.10/32    5094       Fa0/0      192.168.119.11

R8#show bgp vpnv4 unicast all summary

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.10     4            4      17      15        7    0    0 00:10:18        2

R8#show bgp vpnv4 unicast all

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 34:34 (default for vrf 34)
*> 13.13.13.13/32   192.168.138.13           0         32768 ?
*> 14.14.14.14/32   10.10.10.10              0             0 4 ?
*> 192.168.114.0    10.10.10.10              0             0 4 ?
*> 192.168.138.0    0.0.0.0                  0         32768 ?

R13#traceroute 14.14.14.14 source loopback 0
  1 192.168.138.8 60 msec 112 msec 40 msec
  2 192.168.89.9 [MPLS: Labels 18/19 Exp 0] 424 msec 488 msec 352 msec
  3 192.168.119.11 [MPLS: Labels 16/19 Exp 0] 328 msec 336 msec 344 msec
  4 192.168.114.10 [MPLS: Label 19 Exp 0] 316 msec 352 msec 528 msec
  5 192.168.114.14 424 msec 656 msec 404 msec

R13#ping 14.14.14.14 source loopback 0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 268/460/704 ms

No comments:

Post a Comment