Thursday 13 September 2012

InterAS MPLS VPN Section(back-up link through NNI)


In this section, there will be another bgp vpnv4 session between R8 and R10 over NNI AS.
First of all, create another loopback interface on R8 and R10 each and advertise those networks under bgp ipv4 unicast to NNI AS.
Then create a tunnel connecting R8 and R10 over which we will configure bgp vpnv4 session.
Since the link through NNI is considered back-up, so we will configure a route-map with local-preference 200 that will make the path through AS 2 as the primary when applied.

R8 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface Loopback1
 ip address 8.8.8.81 255.255.255.255
!
interface Tunnel0
 ip address 3.4.34.8 255.255.255.0
 mpls bgp forwarding
 tunnel source Loopback1
 tunnel destination 10.10.10.11
!
interface FastEthernet1/0
 ip address 192.168.89.8 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.128.8 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.138.8 255.255.255.0
!
router ospf 1
 network 8.8.8.8 0.0.0.0 area 0
 network 192.168.89.8 0.0.0.0 area 0
!
router bgp 3
 bgp log-neighbor-changes
 neighbor 3.4.34.10 remote-as 4
 neighbor 10.10.10.10 remote-as 4
 neighbor 10.10.10.10 ebgp-multihop 4
 neighbor 10.10.10.10 update-source Loopback0
 neighbor 192.168.128.12 remote-as 12
 !
 address-family ipv4
  no synchronization
  network 8.8.8.81 mask 255.255.255.255
  no neighbor 3.4.34.10 activate
  no neighbor 10.10.10.10 activate
  neighbor 192.168.128.12 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.4.34.10 activate
  neighbor 3.4.34.10 send-community extended
  neighbor 10.10.10.10 activate
  neighbor 10.10.10.10 send-community extended
  neighbor 10.10.10.10 route-map LOCAL-PREFERENCE-200 in
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 13.13.13.13 255.255.255.255 192.168.138.13
!
route-map LOCAL-PREFERENCE-200 permit 10
 set local-preference 200
!
mpls ldp router-id Loopback0 force

R10 Config


ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 10.10.10.11 255.255.255.255
!
interface Tunnel0
 ip address 3.4.34.10 255.255.255.0
 mpls bgp forwarding
 tunnel source Loopback1
 tunnel destination 8.8.8.81
!
interface FastEthernet1/0
 ip address 192.168.110.10 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.112.10 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.114.10 255.255.255.0
!
router ospf 1
 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.110.10 0.0.0.0 area 0
!
router bgp 4
 bgp log-neighbor-changes
 neighbor 3.4.34.8 remote-as 3
 neighbor 8.8.8.8 remote-as 3
 neighbor 8.8.8.8 ebgp-multihop 4
 neighbor 8.8.8.8 update-source Loopback0
 neighbor 192.168.112.12 remote-as 12
 !
 address-family ipv4
  no synchronization
  network 10.10.10.11 mask 255.255.255.255
  no neighbor 3.4.34.8 activate
  no neighbor 8.8.8.8 activate
  neighbor 192.168.112.12 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.4.34.8 activate
  neighbor 3.4.34.8 send-community extended
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
  neighbor 8.8.8.8 route-map LOCAL-PREFERENCE-200 in
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 14.14.14.14 255.255.255.255 192.168.114.14
!
route-map LOCAL-PREFERENCE-200 permit 10
 set local-preference 200
!
mpls ldp router-id Loopback0 force

R12 Config

interface FastEthernet0/0
 ip address 192.168.112.12 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.128.12 255.255.255.0
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.112.10 remote-as 4
 neighbor 192.168.128.8 remote-as 3
 no auto-summary

 Verification

R8#show bgp vpnv4 unicast all summary

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.4.34.10       4            4      24      24       17    0    0 00:17:16        2
10.10.10.10     4            4       7       7       17    0    0 00:00:26        2

R8#show bgp vpnv4 unicast all

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 34:34 (default for vrf 34)
*> 13.13.13.13/32   192.168.138.13           0         32768 ?
*> 14.14.14.14/32   10.10.10.10              0    200      0 4 ?
*                   3.4.34.10                0             0 4 ?
*> 192.168.114.0    10.10.10.10              0    200      0 4 ?
*                   3.4.34.10                0             0 4 ?
*> 192.168.138.0    0.0.0.0                  0         32768 ?

R13#traceroute 14.14.14.14
  1 192.168.138.8 64 msec 40 msec 16 msec
  2 192.168.89.9 [MPLS: Labels 18/17 Exp 0] 344 msec 308 msec 248 msec
  3 192.168.119.11 [MPLS: Labels 16/17 Exp 0] 312 msec 232 msec 280 msec
  4 192.168.114.10 [MPLS: Label 17 Exp 0] 252 msec 300 msec 320 msec
  5 192.168.114.14 324 msec *  304 msec

R13#traceroute 14.14.14.14
  1 192.168.138.8 64 msec 28 msec 52 msec
  2 192.168.114.10 [MPLS: Label 17 Exp 0] 144 msec 68 msec 124 msec
  3 192.168.114.14 120 msec *  132 msec



No comments:

Post a Comment