Wednesday 26 September 2012

QinQ Tunneling


2811 Config

interface FastEthernet0/1.400
 encapsulation dot1Q 1400 second-dot1q 400
 ip address 172.16.40.1 255.255.255.0
!
interface FastEthernet0/1.401
 encapsulation dot1Q 1400 second-dot1q 401
 ip address 172.16.41.1 255.255.255.0
!
interface FastEthernet0/1.402
 encapsulation dot1Q 1400 second-dot1q 402
 ip address 172.16.42.1 255.255.255.0

3750 Config

interface FastEthernet3/0/48
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1400
 switchport mode trunk
 speed 100
 duplex full
!
interface GigabitEthernet3/0/3
 switchport access vlan 1400
 switchport mode dot1q-tunnel
 speed nonegotiate
 mls qos trust ip-precedence
 no cdp enable
 spanning-tree bpdufilter enable

3560 Config

interface GigabitEthernet0/28
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 400-402
 switchport mode trunk
 speed nonegotiate
end
!
interface Vlan400
 ip address 172.16.40.2 255.255.255.0
!
interface Vlan401
 ip address 172.16.41.2 255.255.255.0
!
interface Vlan402
 ip address 172.16.42.2 255.255.255.0

Verification

3750#show dot1q-tunnel
dot1q-tunnel mode LAN Port(s)
-----------------------------
Gi3/0/3

3750#show spanning-tree vlan 1400
VLAN1400
  Spanning tree enabled protocol ieee
  Root ID    Priority    34368
             Address     0022.be7a.8480
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    34368  (priority 32768 sys-id-ext 1400)
             Address     0022.be7a.8480
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi3/0/3          Desg FWD 4         128.135  P2p
Fa3/0/48         Desg FWD 19        128.160  P2p

3560#ping 172.16.40.1
!!!!!

c3560#ping 172.16.41.1
!!!!!

c3560#ping 172.16.42.1
!!!!!

IPv6 routing with RIPng, OSPFv3 and BGP(all routers configuration)

 


R1 Config

ipv6 unicast-routing
!
interface FastEthernet0/0
 ipv6 address 2001:12::1/64
 ipv6 ospf 1 area 0
!
interface FastEthernet0/1
 ipv6 address 2001:13::1/64
 ipv6 ospf 1 area 13
!
ipv6 route 2001:1::1/128 Null0
!
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 summary-prefix 2001:1::/64
 redistribute static

R2 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:2::2/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 ipv6 address 2001:12::2/64
 ipv6 ospf 1 area 0
!
interface FastEthernet0/1
 ipv6 address 2001:24::2/64
 ipv6 ospf 1 area 24
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 24 range 2001:4::/64

R3 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:3::3/128
 ipv6 ospf 1 area 13
!
interface FastEthernet0/0
 ipv6 address 2001:13::3/64
 ipv6 ospf 1 area 13
!
interface FastEthernet0/1
 ipv6 address 2001:35::3/64
 ipv6 rip 35 enable
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute rip 35 tag 120 include-connected
!
ipv6 router rip 35
 distribute-list prefix-list R4-NETWORK out
 redistribute ospf 1 metric 1 route-map TO-RIP
!
ipv6 prefix-list R4-NETWORK seq 5 deny 2001:4::/64
ipv6 prefix-list R4-NETWORK seq 10 permit ::/0 le 128
!
route-map TO-RIP permit 10
 match tag 6
!
route-map TO-RIP deny 20
 match route-type external
!
route-map TO-RIP permit 100

R4 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:4::4/128
 ipv6 ospf 1 area 24
!
interface FastEthernet0/0
 ipv6 address 2001:24::4/64
 ipv6 ospf 1 area 24
!
interface FastEthernet0/1
 ipv6 address 2001:46::4/64
!
router bgp 1
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 neighbor 2001:46::6 remote-as 6
 no neighbor 2001:46::6 activate
 no auto-summary
 !
 address-family ipv6
  neighbor 2001:46::6 activate
  redistribute ospf 1 match external 1 external 2 route-map TO-BGP
  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 redistribute bgp 1 route-map FROM-BGP
!
ipv6 prefix-list FROM-BGP seq 5 permit 2001:6::/57
!
route-map TO-BGP permit 10
 match tag 120
!
route-map FROM-BGP permit 10
 match ipv6 address prefix-list FROM-BGP
 set tag 6

R5 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:5::5/128
 ipv6 rip 35 enable
!
interface FastEthernet0/0
 ipv6 address 2001:35::5/64
 ipv6 rip 35 enable
!
ipv6 router rip 35

R6 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:6:0:6::6/64
!
interface Loopback1
 ipv6 address 2001:6:0:60::6/58
!
interface FastEthernet0/0
 ipv6 address 2001:46::6/64
!
router bgp 6
 no synchronization
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 neighbor 2001:46::4 remote-as 1
 no neighbor 2001:46::4 activate
 no auto-summary
 !
 address-family ipv6
  neighbor 2001:46::4 activate
  network 2001:6:0:6::/64
  network 2001:6:0:60::/58
  aggregate-address 2001:6::/57 summary-only
 exit-address-family


OSPFv3 section


R1 Config

ipv6 unicast-routing
!
interface FastEthernet0/0
 ipv6 address 2001:12::1/64
 ipv6 ospf 1 area 0
!
interface FastEthernet0/1
 ipv6 address 2001:13::1/64
 ipv6 ospf 1 area 13
!
ipv6 route 2001:1::1/128 Null0
!
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 summary-prefix 2001:1::/64
 redistribute static

R2 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:2::2/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 ipv6 address 2001:12::2/64
 ipv6 ospf 1 area 0
!
interface FastEthernet0/1
 ipv6 address 2001:24::2/64
 ipv6 ospf 1 area 24
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 24 range 2001:4::/64

R3 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:3::3/128
 ipv6 ospf 1 area 13
!
interface FastEthernet0/0
 ipv6 address 2001:13::3/64
 ipv6 ospf 1 area 13
!
ipv6 router ospf 1
 router-id 3.3.3.3

R4 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:4::4/128
 ipv6 ospf 1 area 24
!
interface FastEthernet0/0
 ipv6 address 2001:24::4/64
 ipv6 ospf 1 area 24
!
ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes

Verification

R1#show ipv6 route ospf

O   2001:1::/64 [110/0]
     via ::, Null0
O   2001:2::2/128 [110/10]
     via FE80::C603:AFF:FE64:0, FastEthernet0/0
O   2001:3::3/128 [110/10]
     via FE80::C605:CFF:FED4:0, FastEthernet0/1
OI  2001:4::/64 [110/20]
     via FE80::C603:AFF:FE64:0, FastEthernet0/0
OI  2001:24::/64 [110/20]
     via FE80::C603:AFF:FE64:0, FastEthernet0/0

R2#show ipv6 route ospf

OE2  2001:1::/64 [110/20]
     via FE80::C602:AFF:FE64:0, FastEthernet0/0
OI  2001:3::3/128 [110/20]
     via FE80::C602:AFF:FE64:0, FastEthernet0/0
O   2001:4::/64 [110/0]
     via ::, Null0
O   2001:4::4/128 [110/10]
     via FE80::C604:CFF:FED4:0, FastEthernet0/1
OI  2001:13::/64 [110/20]
     via FE80::C602:AFF:FE64:0, FastEthernet0/0

R3#show ipv6 route ospf

OE2  2001:1::/64 [110/20]
     via FE80::C602:AFF:FE64:1, FastEthernet0/0
OI  2001:2::2/128 [110/20]
     via FE80::C602:AFF:FE64:1, FastEthernet0/0
OI  2001:4::/64 [110/30]
     via FE80::C602:AFF:FE64:1, FastEthernet0/0
OI  2001:12::/64 [110/20]
     via FE80::C602:AFF:FE64:1, FastEthernet0/0
OI  2001:24::/64 [110/30]
     via FE80::C602:AFF:FE64:1, FastEthernet0/0

R4#show ipv6 route ospf

OE2  2001:1::/64 [110/20]
     via FE80::C603:AFF:FE64:1, FastEthernet0/0
OI  2001:2::2/128 [110/10]
     via FE80::C603:AFF:FE64:1, FastEthernet0/0
OI  2001:3::3/128 [110/30]
     via FE80::C603:AFF:FE64:1, FastEthernet0/0
OI  2001:12::/64 [110/20]
     via FE80::C603:AFF:FE64:1, FastEthernet0/0
OI  2001:13::/64 [110/30]
     via FE80::C603:AFF:FE64:1, FastEthernet0/0

RIPng Section




R3 Config

ipv6 unicast-routing
!
interface FastEthernet0/1
 ipv6 address 2001:35::3/64
 ipv6 rip 35 enable
!
ipv6 router rip 35

R5 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:5::5/128
 ipv6 rip 35 enable
!
interface FastEthernet0/0
 ipv6 address 2001:35::5/64
 ipv6 rip 35 enable
!
ipv6 router rip 35

Verification

R3#show ipv6 route rip

R   2001:5::5/128 [120/2]
     via FE80::C600:4FF:FE80:0, FastEthernet0/1

IPv6 BGP section(route advertising and aggregation)


R4 Config

 ipv6 unicast-routing
!
interface FastEthernet0/1
 ipv6 address 2001:46::4/64
!
router bgp 1
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 neighbor 2001:46::6 remote-as 6
 no neighbor 2001:46::6 activate
 no auto-summary
 !
 address-family ipv6
  neighbor 2001:46::6 activate
  no synchronization
 exit-address-family

R6 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:6:0:6::6/64
!
interface Loopback1
 ipv6 address 2001:6:0:60::6/58
!
interface FastEthernet0/0
 ipv6 address 2001:46::6/64
!
router bgp 6
 no synchronization
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 neighbor 2001:46::4 remote-as 1
 no neighbor 2001:46::4 activate
 no auto-summary
 !
 address-family ipv6
  neighbor 2001:46::4 activate
  network 2001:6:0:6::/64
  network 2001:6:0:60::/58
  aggregate-address 2001:6::/57 summary-only
 exit-address-family


Verification


R6 is advertising 2001:6:0:6::/64 and 2001:6:0:60::/58.
But those prefixes are suppressed when aggregate with 2001:6:0:60::/57 since those are fall with the aggregate prefix.

R4#show bgp ipv6 unicast

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:6::/57      2001:46::6               0             0 6 i

R6#show bgp ipv6 unicast

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:6::/57      ::                                 32768 i
s> 2001:6:0:6::/64  ::                       0         32768 i
s> 2001:6:0:60::/58 ::                       0         32768 i

Redistribution into OSPFv3 section


R1 Config

ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 summary-prefix 2001:1::/64
 redistribute static
 !
 ipv6 route 2001:1::1/128 Null0

R3 Config

ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute rip 35 tag 120 include-connected

R4 Config

ipv6 router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 redistribute bgp 1 route-map FROM-BGP
!
route-map FROM-BGP permit 10
 match ipv6 address prefix-list FROM-BGP
 set tag 6
!
ipv6 prefix-list FROM-BGP seq 5 permit 2001:6::/57

Verification

R2#show ipv6 route ospf

OE2  2001:1::/64 [110/20]
     via FE80::C602:2CFF:FE20:0, FastEthernet0/0
OI  2001:3::3/128 [110/20]
     via FE80::C602:2CFF:FE20:0, FastEthernet0/0
O   2001:4::4/128 [110/10]
     via FE80::C604:27FF:FE28:0, FastEthernet0/1
OE2  2001:5::5/128 [110/20], tag 120
     via FE80::C602:2CFF:FE20:0, FastEthernet0/0
OE2  2001:6::/57 [110/1], tag 6
     via FE80::C604:27FF:FE28:0, FastEthernet0/1
OI  2001:13::/64 [110/20]
     via FE80::C602:2CFF:FE20:0, FastEthernet0/0
OE2  2001:35::/64 [110/20], tag 120
     via FE80::C602:2CFF:FE20:0, FastEthernet0/0

Redistribution into RIPng section


R3 Config

ipv6 router rip 35
 distribute-list prefix-list R4-NETWORK out
 redistribute ospf 1 metric 1 route-map TO-RIP
!
ipv6 prefix-list R4-NETWORK seq 5 deny 2001:4::/64
ipv6 prefix-list R4-NETWORK seq 10 permit ::/0 le 128
!
route-map TO-RIP permit 10
 match tag 6
!
route-map TO-RIP deny 20
 match route-type external

Verification

R5#show ipv6 route rip

R   2001:2::2/128 [120/2]
     via FE80::C605:27FF:FE28:1, FastEthernet0/0
R   2001:6::/57 [120/2], tag 6
     via FE80::C605:27FF:FE28:1, FastEthernet0/0
R   2001:12::/64 [120/2]
     via FE80::C605:27FF:FE28:1, FastEthernet0/0
R   2001:24::/64 [120/2]
     via FE80::C605:27FF:FE28:1, FastEthernet0/0

Redistribution into BGP section


R4 Config

router bgp 1
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 neighbor 2001:46::6 remote-as 6
 !
 address-family ipv6
  neighbor 2001:46::6 activate
  redistribute ospf 1 match external 1 external 2 route-map TO-BGP
  no synchronization
 exit-address-family
!
route-map TO-BGP permit 10
 match tag 120

Verification

 R6#show bgp ipv6 unicast

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:5::5/128    2001:46::4              20             0 1 ?
*> 2001:6::/57      ::                                 32768 i
s> 2001:6:0:6::/64  ::                       0         32768 i
s> 2001:6:0:60::/58 ::                       0         32768 i
*> 2001:35::/64     2001:46::4              20             0 1 ?



Tuesday 25 September 2012

IPv6 Routing with OSPFv3(Summarization and virtual-link)




In this lab, R4 will announce 2001:4::4/128 prefix into area 24.
When the advertisment reach ABR(R2) of area 24, R2 will summarize it into /64.
Likewise, R1 is also redistributing 2001:1::1/128 route into OSPF domain, since R1 is the ASBR itself, we can summarize it on R1. In this case, we will summarize it into /64.
R3 is not connecting to backbone area, R3 is announcing 2001::3/128 into area 3. The advertisement cannot reach to the rest of the OSPF domain.
In order to reach every other routers, R3 needs to be connected to backbone area which is area 0, so we will build virtual link between R1 and R3 to extend the backbone area to R3.

R1 Config

ipv6 unicast-routing
!
interface FastEthernet0/0
 ipv6 address 2001:12::1/64
 ipv6 ospf 1 area 0
!
interface FastEthernet0/1
 ipv6 address 2001:13::1/64
 ipv6 ospf 1 area 13
!
ipv6 route 2001:1::1/128 Null0
ipv6 router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 area 13 virtual-link 3.3.3.3
 summary-prefix 2001:1::/64
 redistribute static
R2 Config

ipv6 unicast-routing
!
interface FastEthernet0/0
 ipv6 address 2001:12::2/64
 ipv6 ospf 1 area 0
!
interface FastEthernet0/1
 ipv6 address 2001:24::2/64
 ipv6 ospf 1 area 24
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 24 range 2001:4::/64
R3 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001::3/128
 ipv6 ospf 1 area 3
!
interface FastEthernet0/0
 ipv6 address 2001:13::3/64
 ipv6 ospf 1 area 13
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 13 virtual-link 1.1.1.1
 redistribute static

R4 Config

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2001:4::4/128
 ipv6 ospf 1 area 24
!
interface FastEthernet0/0
 ipv6 address 2001:24::4/64
 ipv6 ospf 1 area 24
!
ipv6 router ospf 1
 router-id 4.4.4.4

Verification

R1#show ipv6 route ospf
IPv6 Routing Table - 11 entries
O   2001::3/128 [110/10]
     via FE80::C602:11FF:FE5C:0, FastEthernet0/1
O   2001:1::/64 [110/0]
     via ::, Null0
OI  2001:4::/64 [110/20]
     via FE80::C601:1EFF:FE74:0, FastEthernet0/0
OI  2001:24::/64 [110/20]
     via FE80::C601:1EFF:FE74:0, FastEthernet0/0

R2#show ipv6 route ospf
OI  2001::3/128 [110/20]
     via FE80::C600:1EFF:FE74:0, FastEthernet0/0
OE2  2001:1::/64 [110/20]
     via FE80::C600:1EFF:FE74:0, FastEthernet0/0
O   2001:4::/64 [110/0]
     via ::, Null0
O   2001:4::4/128 [110/10]
     via FE80::C603:11FF:FE5C:0, FastEthernet0/1
OI  2001:12::1/128 [110/10]
     via FE80::C600:1EFF:FE74:0, FastEthernet0/0
OI  2001:13::/64 [110/20]
     via FE80::C600:1EFF:FE74:0, FastEthernet0/0

R3#show ipv6 route ospf
OE2  2001:1::/64 [110/20]
     via FE80::C600:1EFF:FE74:1, FastEthernet0/0
OI  2001:4::/64 [110/30]
     via FE80::C600:1EFF:FE74:1, FastEthernet0/0
O   2001:12::/64 [110/20]
     via FE80::C600:1EFF:FE74:1, FastEthernet0/0
O   2001:12::1/128 [110/10]
     via FE80::C600:1EFF:FE74:1, FastEthernet0/0
OI  2001:24::/64 [110/30]
     via FE80::C600:1EFF:FE74:1, FastEthernet0/0

R4#show ipv6 route ospf
OI  2001::3/128 [110/30]
     via FE80::C601:1EFF:FE74:1, FastEthernet0/0
OE2  2001:1::/64 [110/20]
     via FE80::C601:1EFF:FE74:1, FastEthernet0/0
OI  2001:12::/64 [110/20]
     via FE80::C601:1EFF:FE74:1, FastEthernet0/0
OI  2001:12::1/128 [110/20]
     via FE80::C601:1EFF:FE74:1, FastEthernet0/0
OI  2001:13::/64 [110/30]
     via FE80::C601:1EFF:FE74:1, FastEthernet0/0

Thursday 13 September 2012

ISP Connectioin Overview and Configuration of all Nodes


R1 Config

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip vrf forwarding one
 ip address 192.168.14.1 255.255.255.0
 mpls ip
!
router ospf 2 vrf one
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 192.168.14.1 0.0.0.0 area 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
 network 192.168.13.1 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  redistribute ospf 2 vrf one
 exit-address-family

R2 Config

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 mpls ip
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0

R3 Config

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/1
 ip address 192.168.23.3 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet2/0
 ip vrf forwarding one
 ip address 192.168.36.3 255.255.255.0
 mpls bgp forwarding
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.13.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  neighbor 192.168.36.6 remote-as 2
  neighbor 192.168.36.6 activate
  neighbor 192.168.36.6 send-label
 exit-address-family

R4 Config

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.14.4 255.255.255.0
 mpls ip
!
interface FastEthernet0/1
 ip address 192.168.45.4 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.14.4 0.0.0.0 area 0
 network 192.168.45.4 0.0.0.0 area 0

R5 Config

ip vrf two
 rd 2:2
 route-target export 2:2
 route-target import 2:2
!
pseudowire-class AS3-AS4
 encapsulation mpls
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.45.5 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 xconnect 7.7.7.7 34 pw-class AS3-AS4
!
interface FastEthernet2/0
 ip vrf forwarding two
 ip address 192.168.155.5 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 192.168.45.5 0.0.0.0 area 0
!
router bgp 2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.7.7.7 remote-as 2
 neighbor 7.7.7.7 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 7.7.7.7 activate
  neighbor 7.7.7.7 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf two
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf two 15.15.15.15 255.255.255.255 192.168.155.15

R6 Config

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.36.6 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.67.6 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 redistribute bgp 2 subnets route-map AS2LOOPBACKS
 network 6.6.6.6 0.0.0.0 area 0
 network 192.168.67.6 0.0.0.0 area 0
!
router bgp 2
 bgp log-neighbor-changes
 neighbor 192.168.36.3 remote-as 1
 !
 address-family ipv4
  redistribute ospf 1 route-map AS2LOOPBACKS
  neighbor 192.168.36.3 activate
  neighbor 192.168.36.3 send-label
  no auto-summary
  no synchronization
 exit-address-family
!
ip prefix-list AS2LOOPBACKS seq 5 permit 4.4.4.4/32
ip prefix-list AS2LOOPBACKS seq 10 permit 5.5.5.5/32
ip prefix-list AS2LOOPBACKS seq 15 permit 6.6.6.6/32
ip prefix-list AS2LOOPBACKS seq 20 permit 7.7.7.7/32
!
route-map AS2LOOPBACKS permit 10
 match ip address prefix-list AS2LOOPBACKS

R7 Config

ip vrf two
 rd 2:2
 route-target export 2:2
 route-target import 2:2
!
pseudowire-class AS3-AS4
 encapsulation mpls
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.67.7 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 xconnect 5.5.5.5 34 pw-class AS3-AS4
!
interface FastEthernet2/0
 ip vrf forwarding two
 ip address 192.168.167.7 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 192.168.67.7 0.0.0.0 area 0
!
router bgp 2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 2
 neighbor 5.5.5.5 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf two
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf two 16.16.16.16 255.255.255.255 192.168.167.16

R8 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface Loopback1
 ip address 8.8.8.81 255.255.255.255
!
interface Tunnel0
 ip address 3.4.34.8 255.255.255.0
 mpls bgp forwarding
 tunnel source Loopback1
 tunnel destination 10.10.10.11
!
interface FastEthernet1/0
 ip address 192.168.89.8 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.128.8 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.138.8 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 8.8.8.8 0.0.0.0 area 0
 network 192.168.89.8 0.0.0.0 area 0
!
router bgp 3
 bgp log-neighbor-changes
 neighbor 3.4.34.10 remote-as 4
 neighbor 10.10.10.10 remote-as 4
 neighbor 10.10.10.10 ebgp-multihop 4
 neighbor 10.10.10.10 update-source Loopback0
 neighbor 192.168.128.12 remote-as 12
 !
 address-family ipv4
  no synchronization
  network 8.8.8.81 mask 255.255.255.255
  no neighbor 3.4.34.10 activate
  no neighbor 10.10.10.10 activate
  neighbor 192.168.128.12 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.4.34.10 activate
  neighbor 3.4.34.10 send-community extended
  neighbor 10.10.10.10 activate
  neighbor 10.10.10.10 send-community extended
  neighbor 10.10.10.10 route-map LOCAL-PREFERENCE-200 in
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 13.13.13.13 255.255.255.255 192.168.138.13
!
route-map LOCAL-PREFERENCE-200 permit 10
 set local-preference 200
!
mpls ldp router-id Loopback0 force

R9 Config

interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.119.9 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.89.9 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 redistribute bgp 3 subnets route-map AS4-LOOPBACKS
 network 9.9.9.9 0.0.0.0 area 0
 network 192.168.89.9 0.0.0.0 area 0
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map AS3-LOOPBACKS
 neighbor 192.168.119.11 remote-as 4
 neighbor 192.168.119.11 send-label
 no auto-summary
!
ip prefix-list AS3-LOOPBACKS seq 5 permit 8.8.8.8/32
!
ip prefix-list AS4-LOOPBACKS seq 5 permit 10.10.10.10/32
!
route-map AS3-LOOPBACKS permit 10
 match ip address prefix-list AS3-LOOPBACKS
!
route-map AS4-LOOPBACKS permit 10
 match ip address prefix-list AS4-LOOPBACKS
!
mpls ldp router-id Loopback0 force

R10 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 10.10.10.11 255.255.255.255
!
interface Tunnel0
 ip address 3.4.34.10 255.255.255.0
 mpls bgp forwarding
 tunnel source Loopback1
 tunnel destination 8.8.8.81
!
interface FastEthernet1/0
 ip address 192.168.110.10 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.112.10 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.114.10 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.110.10 0.0.0.0 area 0
!
router bgp 4
 bgp log-neighbor-changes
 neighbor 3.4.34.8 remote-as 3
 neighbor 8.8.8.8 remote-as 3
 neighbor 8.8.8.8 ebgp-multihop 4
 neighbor 8.8.8.8 update-source Loopback0
 neighbor 192.168.112.12 remote-as 12
 !
 address-family ipv4
  no synchronization
  network 10.10.10.11 mask 255.255.255.255
  no neighbor 3.4.34.8 activate
  no neighbor 8.8.8.8 activate
  neighbor 192.168.112.12 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.4.34.8 activate
  neighbor 3.4.34.8 send-community extended
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
  neighbor 8.8.8.8 route-map LOCAL-PREFERENCE-200 in
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 14.14.14.14 255.255.255.255 192.168.114.14
!
route-map LOCAL-PREFERENCE-200 permit 10
 set local-preference 200
!
mpls ldp router-id Loopback0 force

R11 Config

interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.119.11 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.110.11 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 redistribute bgp 4 subnets route-map AS3LOOPBACKS
 network 11.11.11.11 0.0.0.0 area 0
 network 192.168.110.11 0.0.0.0 area 0
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map AS4LOOPBACKS
 neighbor 192.168.119.9 remote-as 3
 neighbor 192.168.119.9 send-label
 no auto-summary
!
ip prefix-list AS3LOOPBACKS seq 5 permit 8.8.8.8/32
!
ip prefix-list AS4LOOPBACKS seq 5 permit 10.10.10.10/32
!
route-map AS4LOOPBACKS permit 10
 match ip address prefix-list AS4LOOPBACKS
!
route-map AS3LOOPBACKS permit 10
 match ip address prefix-list AS3LOOPBACKS
!
mpls ldp router-id Loopback0 force

R12 Config

interface FastEthernet0/0
 ip address 192.168.112.12 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.128.12 255.255.255.0
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.112.10 remote-as 4
 neighbor 192.168.128.8 remote-as 3
 no auto-summary

R13 Config

interface Loopback0
 ip address 13.13.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.138.13 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.138.8

R14 Config

interface Loopback0
 ip address 14.14.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.114.14 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.114.10

R15 Config

interface Loopback0
 ip address 15.15.15.15 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.155.15 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.155.5

R16 Config

interface Loopback0
 ip address 16.16.16.16 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.167.16 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.167.7



Carrier-Supporting-Carrier Section



In this lab, AS1 is the carrier AS.
Fe2/0 of R1 and R3 is configured under vrf one and connected to R4 and R6 respectively.
Between R1 and R4, ldp is used for label binding, between R3 and R6, bgp is used for label binding with the command "neighbor x.x.x.x send-label"
In AS2, R5 and R7 are vpnv4 peers and provide l3vpn service to R15 and R16.

R1 Config

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip vrf forwarding one
 ip address 192.168.14.1 255.255.255.0
 mpls ip
!
router ospf 2 vrf one
 log-adjacency-changes
 redistribute bgp 1 subnets
 network 192.168.14.1 0.0.0.0 area 0
!
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
 network 192.168.13.1 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  redistribute ospf 2 vrf one
 exit-address-family

R2 Config

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 mpls ip
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0
!

R3 Config

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/1
 ip address 192.168.23.3 255.255.255.0
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet2/0
 ip vrf forwarding one
 ip address 192.168.36.3 255.255.255.0
 mpls bgp forwarding
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.13.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  neighbor 192.168.36.6 remote-as 2
  neighbor 192.168.36.6 activate
  neighbor 192.168.36.6 send-label
 exit-address-family

R4 Config

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.14.4 255.255.255.0
 mpls ip
!
interface FastEthernet0/1
 ip address 192.168.45.4 255.255.255.0
 mpls ip
!
router ospf 1
 network 4.4.4.4 0.0.0.0 area 0
 network 192.168.14.4 0.0.0.0 area 0
 network 192.168.45.4 0.0.0.0 area 0

R5 Config

ip vrf two
 rd 2:2
 route-target export 2:2
 route-target import 2:2
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.45.5 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip vrf forwarding two
 ip address 192.168.155.5 255.255.255.0
!
router ospf 1
 network 5.5.5.5 0.0.0.0 area 0
 network 192.168.45.5 0.0.0.0 area 0
!
router bgp 2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 7.7.7.7 remote-as 2
 neighbor 7.7.7.7 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 7.7.7.7 activate
  neighbor 7.7.7.7 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf two
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf two 15.15.15.15 255.255.255.255 192.168.155.15

R6 Config

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.36.6 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.67.6 255.255.255.0
 mpls ip
!
router ospf 1
 redistribute bgp 2 subnets route-map AS2LOOPBACKS
 network 6.6.6.6 0.0.0.0 area 0
 network 192.168.67.6 0.0.0.0 area 0
!
router bgp 2
 bgp log-neighbor-changes
 neighbor 192.168.36.3 remote-as 1
 !
 address-family ipv4
  redistribute ospf 1 route-map AS2LOOPBACKS
  neighbor 192.168.36.3 activate
  neighbor 192.168.36.3 send-label
  no auto-summary
  no synchronization
!
ip prefix-list AS2LOOPBACKS seq 5 permit 4.4.4.4/32
ip prefix-list AS2LOOPBACKS seq 10 permit 5.5.5.5/32
ip prefix-list AS2LOOPBACKS seq 15 permit 6.6.6.6/32
ip prefix-list AS2LOOPBACKS seq 20 permit 7.7.7.7/32
!
route-map AS2LOOPBACKS permit 10
 match ip address prefix-list AS2LOOPBACKS

R7 Config

ip vrf two
 rd 2:2
 route-target export 2:2
 route-target import 2:2
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.67.7 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip vrf forwarding two
 ip address 192.168.167.7 255.255.255.0
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 0
 network 192.168.67.7 0.0.0.0 area 0
!
router bgp 2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 2
 neighbor 5.5.5.5 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf two
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf two 16.16.16.16 255.255.255.255 192.168.167.16

R15 Config

interface Loopback0
 ip address 15.15.15.15 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.155.15 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.155.5

R16 Config

interface Loopback0
 ip address 16.16.16.16 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.167.16 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.167.7


Verification

AS2 loopback networks used to peer vpnv4 session

R5#show ip route ospf

      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/2] via 192.168.45.4, 03:36:16, FastEthernet1/0
      6.0.0.0/32 is subnetted, 1 subnets
O E2     6.6.6.6 [110/1] via 192.168.45.4, 03:21:56, FastEthernet1/0
      7.0.0.0/32 is subnetted, 1 subnets
O E2     7.7.7.7 [110/1] via 192.168.45.4, 03:21:56, FastEthernet1/0
O     192.168.14.0/24 [110/2] via 192.168.45.4, 03:36:06, FastEthernet1/0

R5#traceroute 7.7.7.7 source loopback 0

Type escape sequence to abort.
Tracing the route to 7.7.7.7

  1 192.168.45.4 [MPLS: Label 18 Exp 0] 120 msec 104 msec 92 msec
  2 192.168.14.1 [MPLS: Label 24 Exp 0] 136 msec 132 msec 100 msec
  3 192.168.12.2 [MPLS: Labels 17/25 Exp 0] 112 msec 108 msec 100 msec
  4 192.168.36.3 [MPLS: Label 25 Exp 0] 148 msec 140 msec 136 msec
  5 192.168.36.6 [MPLS: Label 16 Exp 0] 132 msec 112 msec 128 msec
  6 192.168.67.7 176 msec *  188 msec

R5#show mpls forwarding-table
20         18         7.7.7.7/32       0             Fa1/0      192.168.45.4

R4#show mpls forwarding-table
18     24          7.7.7.7/32        33425      Fa0/0      192.168.14.1

R1#show mpls forwarding-table
21         17         3.3.3.3/32       0             Fa1/0      192.168.12.2
R1#show bgp vpnv4 unicast all labels
    7.7.7.7/32       3.3.3.3         nolabel/25


R3#show mpls forwarding-table
25         16         7.7.7.7/32[V]    41978         Fa2/0      192.168.36.6


l3vpn clients reachability

R15#ping 16.16.16.16 source loopback 0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/108/144 ms

R15#traceroute 16.16.16.16 source loopback 0

  1 192.168.155.5 12 msec 40 msec 20 msec
  2 192.168.45.4 [MPLS: Labels 18/20 Exp 0] 120 msec 120 msec 68 msec
  3 192.168.14.1 [MPLS: Labels 24/20 Exp 0] 112 msec 124 msec 136 msec
  4 192.168.12.2 [MPLS: Labels 17/25/20 Exp 0] 104 msec 84 msec 60 msec
  5 192.168.23.3 [MPLS: Labels 25/20 Exp 0] 120 msec 120 msec 88 msec
  6 192.168.36.6 [MPLS: Labels 16/20 Exp 0] 104 msec 124 msec 96 msec
  7 192.168.167.7 [MPLS: Label 20 Exp 0] 76 msec 108 msec 92 msec
  8 192.168.167.16 112 msec *  124 msec


MPLS AToM Section


In this lab, we will configure MPLS AToM on R5 and R7 to provide layer 2 connectivity to R9 and R11 as if they were directly connected.


R5 Config

pseudowire-class AS3-AS4
 encapsulation mpls
!
interface FastEthernet1/1
 xconnect 7.7.7.7 34 pw-class AS3-AS4

R7 Config

pseudowire-class AS3-AS4
 encapsulation mpls
!
interface FastEthernet1/1
 xconnect 5.5.5.5 34 pw-class AS3-AS4

R9 Config

interface FastEthernet0/0
 ip address 192.168.119.9 255.255.255.0

R11 Config

interface FastEthernet0/0
 ip address 192.168.119.11 255.255.255.0

Verification

R5#show mpls l2transport vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa1/1          Ethernet                   7.7.7.7         34         UP

R5#show mpls ldp neighbor
       Peer LDP Ident: 7.7.7.7:0; Local LDP Ident 5.5.5.5:0
        TCP connection: 7.7.7.7.59029 - 5.5.5.5.646
        State: Oper; Msgs sent/rcvd: 34/32; Downstream
        Up time: 00:21:13
        LDP discovery sources:
          Targeted Hello 5.5.5.5 -> 7.7.7.7, active, passive
        Addresses bound to peer LDP Ident:
          192.168.67.7    7.7.7.7
 
R7#show mpls l2transport vc

Local intf     Local circuit              Dest address    VC ID      Status
-------------  -------------------------- --------------- ---------- ----------
Fa1/1          Ethernet                   5.5.5.5         34         UP

R9#ping 192.168.119.11
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/112/156 ms


Inter-AS MPLS VPN Option 2C Section(Through AToM AS2 Link)


By this time, R9 and R11 have a direct layer 2 connection through AS2.
AS3 of R8 and AS4 of R10 will peer bgp vpnv4 session.
In order to do so, we need TCP connection and label switch path(R8>R9>R11>R10) between the loopback networks of R8 and R10.
Between R9 and R11, bgp will be used to map the labels.

R8 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.89.8 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.128.8 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.138.8 255.255.255.0
!
router ospf 1

 network 8.8.8.8 0.0.0.0 area 0
 network 192.168.89.8 0.0.0.0 area 0
!
router bgp 3
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.10.10.10 remote-as 4
 neighbor 10.10.10.10 ebgp-multihop 4
 neighbor 10.10.10.10 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.10.10.10 activate
  neighbor 10.10.10.10 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 13.13.13.13 255.255.255.255 192.168.138.13
!

mpls ldp router-id Loopback0 force


R9 Config

interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.119.9 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.89.9 255.255.255.0
 mpls ip
!
router ospf 1

 redistribute bgp 3 subnets route-map AS4-LOOPBACKS
 network 9.9.9.9 0.0.0.0 area 0
 network 192.168.89.9 0.0.0.0 area 0
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map AS3-LOOPBACKS
 neighbor 192.168.119.11 remote-as 4
 neighbor 192.168.119.11 send-label
 no auto-summary
!
ip prefix-list AS3-LOOPBACKS seq 5 permit 8.8.8.8/32
!
ip prefix-list AS4-LOOPBACKS seq 5 permit 10.10.10.10/32
!
route-map AS3-LOOPBACKS permit 10
 match ip address prefix-list AS3-LOOPBACKS
!
route-map AS4-LOOPBACKS permit 10
 match ip address prefix-list AS4-LOOPBACKS
!

mpls ldp router-id Loopback0 force

R10 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.110.10 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.112.10 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.114.10 255.255.255.0
!
router ospf 1

 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.110.10 0.0.0.0 area 0
!
router bgp 4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 8.8.8.8 remote-as 3
 neighbor 8.8.8.8 ebgp-multihop 4
 neighbor 8.8.8.8 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 14.14.14.14 255.255.255.255 192.168.114.14
!

mpls ldp router-id Loopback0 force

R11 Config

interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.119.11 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.110.11 255.255.255.0
 mpls ip
!
router ospf 1

 redistribute bgp 4 subnets route-map AS3LOOPBACKS
 network 11.11.11.11 0.0.0.0 area 0
 network 192.168.110.11 0.0.0.0 area 0
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 redistribute ospf 1 route-map AS4LOOPBACKS
 neighbor 192.168.119.9 remote-as 3
 neighbor 192.168.119.9 send-label
 no auto-summary
!
ip prefix-list AS3LOOPBACKS seq 5 permit 8.8.8.8/32
!
ip prefix-list AS4LOOPBACKS seq 5 permit 10.10.10.10/32
!
route-map AS4LOOPBACKS permit 10
 match ip address prefix-list AS4LOOPBACKS
!
route-map AS3LOOPBACKS permit 10
 match ip address prefix-list AS3LOOPBACKS
!

mpls ldp router-id Loopback0 force

R13 Config

interface Loopback0
 ip address 13.13.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.138.13 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.138.8

R14 Config

interface Loopback0
 ip address 14.14.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.114.14 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.114.10

 Verification

R8#ping 10.10.10.10 source loopback 0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 224/292/344 ms

R8#traceroute 10.10.10.10 source loopback 0
  1 192.168.89.9 [MPLS: Label 18 Exp 0] 344 msec 192 msec 232 msec
  2 192.168.119.11 [MPLS: Label 16 Exp 0] 292 msec 228 msec 320 msec
  3 192.168.110.10 320 msec *  468 msec

R8#show mpls forwarding-table
17         18         10.10.10.10/32   0             Fa1/0      192.168.89.9

R9#show mpls forwarding-table
18     16          10.10.10.10/32    5094       Fa0/0      192.168.119.11

R8#show bgp vpnv4 unicast all summary

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.10     4            4      17      15        7    0    0 00:10:18        2

R8#show bgp vpnv4 unicast all

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 34:34 (default for vrf 34)
*> 13.13.13.13/32   192.168.138.13           0         32768 ?
*> 14.14.14.14/32   10.10.10.10              0             0 4 ?
*> 192.168.114.0    10.10.10.10              0             0 4 ?
*> 192.168.138.0    0.0.0.0                  0         32768 ?

R13#traceroute 14.14.14.14 source loopback 0
  1 192.168.138.8 60 msec 112 msec 40 msec
  2 192.168.89.9 [MPLS: Labels 18/19 Exp 0] 424 msec 488 msec 352 msec
  3 192.168.119.11 [MPLS: Labels 16/19 Exp 0] 328 msec 336 msec 344 msec
  4 192.168.114.10 [MPLS: Label 19 Exp 0] 316 msec 352 msec 528 msec
  5 192.168.114.14 424 msec 656 msec 404 msec

R13#ping 14.14.14.14 source loopback 0
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 268/460/704 ms

InterAS MPLS VPN Section(back-up link through NNI)


In this section, there will be another bgp vpnv4 session between R8 and R10 over NNI AS.
First of all, create another loopback interface on R8 and R10 each and advertise those networks under bgp ipv4 unicast to NNI AS.
Then create a tunnel connecting R8 and R10 over which we will configure bgp vpnv4 session.
Since the link through NNI is considered back-up, so we will configure a route-map with local-preference 200 that will make the path through AS 2 as the primary when applied.

R8 Config

ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface Loopback1
 ip address 8.8.8.81 255.255.255.255
!
interface Tunnel0
 ip address 3.4.34.8 255.255.255.0
 mpls bgp forwarding
 tunnel source Loopback1
 tunnel destination 10.10.10.11
!
interface FastEthernet1/0
 ip address 192.168.89.8 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.128.8 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.138.8 255.255.255.0
!
router ospf 1
 network 8.8.8.8 0.0.0.0 area 0
 network 192.168.89.8 0.0.0.0 area 0
!
router bgp 3
 bgp log-neighbor-changes
 neighbor 3.4.34.10 remote-as 4
 neighbor 10.10.10.10 remote-as 4
 neighbor 10.10.10.10 ebgp-multihop 4
 neighbor 10.10.10.10 update-source Loopback0
 neighbor 192.168.128.12 remote-as 12
 !
 address-family ipv4
  no synchronization
  network 8.8.8.81 mask 255.255.255.255
  no neighbor 3.4.34.10 activate
  no neighbor 10.10.10.10 activate
  neighbor 192.168.128.12 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.4.34.10 activate
  neighbor 3.4.34.10 send-community extended
  neighbor 10.10.10.10 activate
  neighbor 10.10.10.10 send-community extended
  neighbor 10.10.10.10 route-map LOCAL-PREFERENCE-200 in
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 13.13.13.13 255.255.255.255 192.168.138.13
!
route-map LOCAL-PREFERENCE-200 permit 10
 set local-preference 200
!
mpls ldp router-id Loopback0 force

R10 Config


ip vrf 34
 rd 34:34
 route-target export 34:34
 route-target import 34:34
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 10.10.10.11 255.255.255.255
!
interface Tunnel0
 ip address 3.4.34.10 255.255.255.0
 mpls bgp forwarding
 tunnel source Loopback1
 tunnel destination 8.8.8.81
!
interface FastEthernet1/0
 ip address 192.168.110.10 255.255.255.0
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.112.10 255.255.255.0
!
interface FastEthernet2/0
 ip vrf forwarding 34
 ip address 192.168.114.10 255.255.255.0
!
router ospf 1
 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.110.10 0.0.0.0 area 0
!
router bgp 4
 bgp log-neighbor-changes
 neighbor 3.4.34.8 remote-as 3
 neighbor 8.8.8.8 remote-as 3
 neighbor 8.8.8.8 ebgp-multihop 4
 neighbor 8.8.8.8 update-source Loopback0
 neighbor 192.168.112.12 remote-as 12
 !
 address-family ipv4
  no synchronization
  network 10.10.10.11 mask 255.255.255.255
  no neighbor 3.4.34.8 activate
  no neighbor 8.8.8.8 activate
  neighbor 192.168.112.12 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.4.34.8 activate
  neighbor 3.4.34.8 send-community extended
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
  neighbor 8.8.8.8 route-map LOCAL-PREFERENCE-200 in
 exit-address-family
 !
 address-family ipv4 vrf 34
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf 34 14.14.14.14 255.255.255.255 192.168.114.14
!
route-map LOCAL-PREFERENCE-200 permit 10
 set local-preference 200
!
mpls ldp router-id Loopback0 force

R12 Config

interface FastEthernet0/0
 ip address 192.168.112.12 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.128.12 255.255.255.0
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.112.10 remote-as 4
 neighbor 192.168.128.8 remote-as 3
 no auto-summary

 Verification

R8#show bgp vpnv4 unicast all summary

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.4.34.10       4            4      24      24       17    0    0 00:17:16        2
10.10.10.10     4            4       7       7       17    0    0 00:00:26        2

R8#show bgp vpnv4 unicast all

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 34:34 (default for vrf 34)
*> 13.13.13.13/32   192.168.138.13           0         32768 ?
*> 14.14.14.14/32   10.10.10.10              0    200      0 4 ?
*                   3.4.34.10                0             0 4 ?
*> 192.168.114.0    10.10.10.10              0    200      0 4 ?
*                   3.4.34.10                0             0 4 ?
*> 192.168.138.0    0.0.0.0                  0         32768 ?

R13#traceroute 14.14.14.14
  1 192.168.138.8 64 msec 40 msec 16 msec
  2 192.168.89.9 [MPLS: Labels 18/17 Exp 0] 344 msec 308 msec 248 msec
  3 192.168.119.11 [MPLS: Labels 16/17 Exp 0] 312 msec 232 msec 280 msec
  4 192.168.114.10 [MPLS: Label 17 Exp 0] 252 msec 300 msec 320 msec
  5 192.168.114.14 324 msec *  304 msec

R13#traceroute 14.14.14.14
  1 192.168.138.8 64 msec 28 msec 52 msec
  2 192.168.114.10 [MPLS: Label 17 Exp 0] 144 msec 68 msec 124 msec
  3 192.168.114.14 120 msec *  132 msec



Wednesday 12 September 2012

L3VPN QOS PIPE MODE


In this lab, I don't apply proper QOS on CE routers except marking IPP bit.
We will consider only traffic flow direction from R5 towards R6.
We assume there is no congestion in the core, and there is no QOS configuration for the core network.
We will focus only on PE routers for this topic.

R1 Config

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
class-map match-all IPP1
 match ip precedence 1
class-map match-all IPP3
 match ip precedence 3
class-map match-all IPP5
 match ip precedence 5
!
policy-map IPP-TO-EXP
 class IPP5
  set mpls experimental imposition 5
    police 2000000 conform-action transmit  exceed-action drop
 class IPP3
  set mpls experimental imposition 3
 class IPP1
  set mpls experimental imposition 1
policy-map PARENT-POLICY
 class class-default
    police 8000000 conform-action transmit  exceed-action drop
  service-policy IPP-TO-EXP
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip ospf 1 area 0
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding one
 ip address 192.168.15.1 255.255.255.0
 service-policy input PARENT-POLICY
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 1
 neighbor 4.4.4.4 update-source Loopback0
 !
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  redistribute connected
  redistribute static
  no synchronization
 exit-address-family
!
ip route vrf one 5.5.5.5 255.255.255.255 192.168.15.5
ip route vrf one 5.5.5.51 255.255.255.255 192.168.15.5
ip route vrf one 5.5.5.52 255.255.255.255 192.168.15.5

R2 Config

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip ospf 1 area 0
 mpls ip
!
interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0
 ip ospf 1 area 0
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes

R4 Config

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
class-map match-all IPP1
 match ip precedence 1
class-map match-all IPP3
 match ip precedence 3
class-map match-all IPP5
 match ip precedence 5
!
policy-map TOWARDS-CE
 class IPP5
  priority 2000
    police 2000000 conform-action transmit  exceed-action drop
 class IPP3
  bandwidth 2000
 class IPP1
  bandwidth 3000
policy-map PARENT-POLICY
 class class-default
  shape average 8000000
  service-policy TOWARDS-CE
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 192.168.34.4 255.255.255.0
 ip ospf 1 area 0
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding one
 ip address 192.168.46.4 255.255.255.0
 service-policy output PARENT-POLICY
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
!
router bgp 1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  redistribute connected
  no synchronization
 exit-address-family

R5 Config

class-map match-all LOOPBACK2
 match access-group name LOOPBACK2
class-map match-all LOOPBACK1
 match access-group name LOOPBACK1
class-map match-all LOOPBACK0
 match access-group name LOOPBACK0
!
policy-map MARK-IPP
 class LOOPBACK0
  set ip precedence 5
 class LOOPBACK1
  set ip precedence 3
 class LOOPBACK2
  set ip precedence 1
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
 ip address 5.5.5.51 255.255.255.255
!
interface Loopback2
 ip address 5.5.5.52 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.15.5 255.255.255.0
 service-policy output MARK-IPP
!
ip route 0.0.0.0 0.0.0.0 192.168.15.1
!
ip access-list extended LOOPBACK0
 permit ip host 5.5.5.5 any
ip access-list extended LOOPBACK1
 permit ip host 5.5.5.51 any
ip access-list extended LOOPBACK2
 permit ip host 5.5.5.52 any

R6 Config

interface FastEthernet0/0
 ip address 192.168.46.6 255.255.255.0
 ip access-group TEST in
!
ip route 0.0.0.0 0.0.0.0 192.168.46.4
!
ip access-list extended TEST
 permit ip any any precedence routine
 permit ip any any precedence priority
 permit ip any any precedence immediate
 permit ip any any precedence flash
 permit ip any any precedence flash-override
 permit ip any any precedence critical
 permit ip any any precedence internet
 permit ip any any precedence network


Verification

-When packets are transmitted from  R5 towards R6, packets will be marked IPP bit accordingly as policy defined on R5. Once those packets enter MPLS network, ingress PE (R1) will mapped IPP to MPLS EXP bit and apply proper treatment as per SLA. In this configuration mode, egress PE(R4) will not modifed original IPP bit when it forwarding out to CE(R6), say, if R5 sends packets with IPP bit 3, R6 will receive packets with the same IPP bit. In order to test this, I created ACL and apply on R6 interface connecting to R4.

R5#show policy-map interface fastEthernet 0/0
 FastEthernet0/0

  Service-policy output: MARK-IPP

    Class-map: LOOPBACK0 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name LOOPBACK0
      QoS Set
        precedence 5
          Packets marked 0

    Class-map: LOOPBACK1 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name LOOPBACK1
      QoS Set
        precedence 3
          Packets marked 0

    Class-map: LOOPBACK2 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group name LOOPBACK2
      QoS Set
        precedence 1
          Packets marked 0

    Class-map: class-default (match-any)
      52 packets, 5852 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

-So far we don't see hit counts on R6.

R6#show ip access-lists
Extended IP access list TEST
    10 permit ip any any precedence routine
    20 permit ip any any precedence priority
    30 permit ip any any precedence immediate
    40 permit ip any any precedence flash
    50 permit ip any any precedence flash-override
    60 permit ip any any precedence critical
    70 permit ip any any precedence internet
    80 permit ip any any precedence network

R5#ping 192.168.46.6 source loopback 0 repeat 1
Packet sent with a source address of 5.5.5.5
!

R5#ping 192.168.46.6 source loopback 1 repeat 2
Packet sent with a source address of 5.5.5.51
!!

R5#ping 192.168.46.6 source loopback 2 repeat 3
Packet sent with a source address of 5.5.5.52
!!!

-We will see that ACL hit counts on R6 is incrementing proportionally.

 R6#show ip access-lists
Extended IP access list TEST
    10 permit ip any any precedence routine
    20 permit ip any any precedence priority (9 matches)
    30 permit ip any any precedence immediate
    40 permit ip any any precedence flash (6 matches)
    50 permit ip any any precedence flash-override
    60 permit ip any any precedence critical (3 matches)
    70 permit ip any any precedence internet
    80 permit ip any any precedence network


-Now let's check MPLS packets are marked and switched correctly in core network.
In order to test this, I captured the packets on the link between R1 and R2.

 R5#ping 192.168.46.6 source loopback 1 repeat 2
!!


-On ingress PE(R1), I limit incoming traffic from CE router at 8M. Anything above 8M will be dropped. Within that 8M limit, I even control the IPP5 traffic not to go above 2M.
-On egress PE(R4), I shape the traffic up to 8M. Within that 8M queue, I give priority(latency guarantee) to IPP5 traffic and police at 2M. And also guarantee 2M and 3M to IPP3 and IPP1 streams accordingly.
Since this is gns3 lab, I can't test it to prove my config works as it is intended.

JUNOS MPLS QOS






This lab refers to the previous diagram and scenario.
JUNOS config is not the actual one involved in this lab.
It is the similar configuration providing MPLS QOS treatment in the core.

JUNOS Config

classifiers
exp MPLS-EXP-INGRESS
forwarding-class EXP5
loss-priority low code-points 101
!
forwarding-class EXP3
loss-priority low code-points 011
!
forwarding-class EXP1
loss-priority high code-points 001
!     
interface ge-1/0/0 scheduler-map MPLS-EXP-EGRESS
unit 0
classifiers exp MPLS-EXP-INGRESS
rewrite-rules exp MPLS-EXP-REWRITE
!
interface ge-1/0/1 scheduler-map MPLS-EXP-EGRESS
unit 0
classifiers exp MPLS-EXP-INGRESS;
rewrite-rules exp MPLS-EXP-REWRITE
!
rewrite-rules
exp MPLS-EXP-REWRITE
!
forwarding-class EXP5
loss-priority low code-point 101
!
forwarding-class EXP3
loss-priority low code-point 011
!
forwarding-class EXP1
loss-priority high code-point 100
!
scheduler-maps
MPLS-EXP-EGRESS
forwarding-class network-control scheduler NETWORK-CONTROL
forwarding-class EXP5 scheduler PRIORITY-EGRESS
forwarding-class EXP3 scheduler BANDWIDTH-EGRESS
forwarding-class EXP1 scheduler STANDARD-EGRESS
!
schedulers
PRIORITY-EGRESS
transmit-rate percent 10 exact
priority high
!
BANDWIDTH-EGRESS
transmit-rate percent 10 exact
priority high
!
STANDARD-EGRESS
transmit-rate remainder
priority low
!
NETWORK-CONTROL
transmit-rate percent 5
buffer-size percent 5
priority high;