Sunday 3 February 2013

Load-balancing with Traffic Engineering


Tunnels on R1

Tunnel 0 - R1>R2
Tunnel 1 - R1>R3>R2

Traffic going from R1 to R2 and destination behind R2 will be load-balanced 1:2 ratio between Tu0 and Tu1.

Configuration

R1

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel mode mpls traffic-eng
 tunnel destination 2.2.2.2
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 10 explicit name short
 tunnel mpls traffic-eng load-share 1
!
interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 tunnel mode mpls traffic-eng
 tunnel destination 2.2.2.2
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 10 explicit name long
 tunnel mpls traffic-eng load-share 2
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet1/1
 ip address 192.168.13.1 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
 ip rsvp bandwidth
!
interface FastEthernet2/0
 ip vrf forwarding one
 ip address 192.168.14.1 255.255.255.0
 speed 100
 duplex full
!
interface FastEthernet2/1
 ip address 192.168.16.1 255.255.255.0
 speed auto
 duplex auto
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
 network 192.168.13.1 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 192.168.16.6 remote-as 6
 no auto-summary
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
no ip http server
no ip http secure-server
ip route vrf one 4.4.4.4 255.255.255.255 192.168.14.4
!
ip explicit-path name short enable
 next-address 192.168.12.2
!
ip explicit-path name long enable
 next-address 192.168.13.3
 next-address 192.168.23.2
R2

ip vrf one
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip ospf network point-to-point
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
!
interface FastEthernet1/1
 ip address 192.168.23.2 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
!
interface FastEthernet2/0
 ip vrf forwarding one
 ip address 192.168.25.2 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet2/1
 ip address 192.168.28.2 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet3/0
 ip address 192.168.27.2 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0
 network 192.168.27.2 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 192.168.28.8 remote-as 8
 no auto-summary
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf one 5.5.5.1 255.255.255.255 192.168.25.5
ip route vrf one 5.5.5.5 255.255.255.255 192.168.25.5
R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.13.3 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
!
interface FastEthernet1/1
 ip address 192.168.23.3 255.255.255.0
 speed auto
 duplex auto
 mpls ip
 mpls traffic-eng tunnels
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.13.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 route-reflector-client
 neighbor 2.2.2.2 remote-as 1
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 route-reflector-client
 neighbor 7.7.7.7 remote-as 1
 neighbor 7.7.7.7 update-source Loopback0
 neighbor 7.7.7.7 route-reflector-client
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
  neighbor 1.1.1.1 route-reflector-client
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
  neighbor 2.2.2.2 route-reflector-client
 exit-address-family
R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.14.4 255.255.255.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.14.1
R5

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
 ip address 5.5.5.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.25.5 255.255.255.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.25.2
R6

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.16.6 255.255.255.0
!
router bgp 6
 no synchronization
 bgp log-neighbor-changes
 network 6.6.6.6 mask 255.255.255.255
 neighbor 192.168.16.1 remote-as 1
 no auto-summary
R7

interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.27.7 255.255.255.0
 speed 100
 full-duplex
 mpls ip
 mpls traffic-eng tunnels
!
interface FastEthernet0/1
 ip address 192.168.79.7 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 192.168.27.7 0.0.0.0 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 1
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 next-hop-self
 neighbor 192.168.79.9 remote-as 9
 no auto-summary
R8

interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface Loopback1
 ip address 8.8.8.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.28.8 255.255.255.0
!
router bgp 8
 no synchronization
 bgp log-neighbor-changes
 network 8.8.8.1 mask 255.255.255.255
 network 8.8.8.8 mask 255.255.255.255
 neighbor 192.168.28.2 remote-as 1
 no auto-summary
R9

interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface Loopback1
 ip address 9.9.9.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.79.9 255.255.255.0
!
router bgp 9
 no synchronization
 bgp log-neighbor-changes
 network 9.9.9.1 mask 255.255.255.255
 network 9.9.9.9 mask 255.255.255.255
 neighbor 192.168.79.7 remote-as 1
 no auto-summary


gns flle : http://www.4shared.com/account/home.jsp#dir=pU3Lbsqw

No comments:

Post a Comment