Thursday 14 February 2013

IPv6 6VPE


Configuration

R1

vrf definition one
 rd 1:1
 !
 address-family ipv4
 route-target export 1:1
 route-target import 1:1
 exit-address-family
 !
 address-family ipv6
 route-target export 1:1
 route-target import 1:1
 exit-address-family
ipv6 unicast-routing
ipv6 cef
!
mpls ldp neighbor 2.2.2.2 password cisco
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 vrf forwarding one
 ip address 192.168.14.1 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:1:4::1/64
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
!
router bgp 13
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 13
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family vpnv6
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  neighbor 192.168.14.4 remote-as 45
  neighbor 192.168.14.4 activate
  neighbor 192.168.14.4 as-override
 exit-address-family
 !
 address-family ipv6 vrf one
  no synchronization
  neighbor 2001:0:1:4::4 remote-as 45
  neighbor 2001:0:1:4::4 activate
  neighbor 2001:0:1:4::4 as-override
 exit-address-family

R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.23.2 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0

R3

vrf definition one
 rd 3:3
 !
 address-family ipv4
 route-target export 1:1
 route-target import 1:1
 exit-address-family
 !
 address-family ipv6
 route-target export 1:1
 route-target import 1:1
 exit-address-family
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.23.3 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 vrf forwarding one
 ip address 192.168.35.3 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:3:5::3/64
!
router ospf 1
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 192.168.23.3 0.0.0.0 area 0
!
router bgp 13
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 13
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
 !
 address-family vpnv6
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf one
  no synchronization
  neighbor 192.168.35.5 remote-as 45
  neighbor 192.168.35.5 activate
  neighbor 192.168.35.5 as-override
 exit-address-family
 !
 address-family ipv6 vrf one
  no synchronization
  neighbor 2001:0:3:5::5 remote-as 45
  neighbor 2001:0:3:5::5 activate
  neighbor 2001:0:3:5::5 as-override
 exit-address-family

R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ipv6 address 2001:0:0:4::4/128
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.14.4 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:1:4::4/64
!
interface FastEthernet1/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router bgp 45
 bgp log-neighbor-changes
 neighbor 2001:0:1:4::1 remote-as 13
 neighbor 192.168.14.1 remote-as 13
 !
 address-family ipv4
  no synchronization
  network 4.4.4.4 mask 255.255.255.255
  no neighbor 2001:0:1:4::1 activate
  neighbor 192.168.14.1 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  network 2001:0:0:4::4/128
  neighbor 2001:0:1:4::1 activate
 exit-address-family

R5

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ipv6 address 2001:0:0:5::5/128
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.35.5 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:3:5::5/64
!
interface FastEthernet1/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router bgp 45
 bgp log-neighbor-changes
 neighbor 2001:0:3:5::3 remote-as 13
 neighbor 192.168.35.3 remote-as 13
 !
 address-family ipv4
  no synchronization
  network 5.5.5.5 mask 255.255.255.255
  no neighbor 2001:0:3:5::3 activate
  neighbor 192.168.35.3 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  network 2001:0:0:5::5/128
  neighbor 2001:0:3:5::3 activate
 exit-address-family

GNS File : http://www.4shared.com/rar/wjwJGD4L/ipv6_6vpe.html

No comments:

Post a Comment