Wednesday 13 February 2013

IPv6 6PE



Configuration

R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 ip router isis
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.14.1 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:1:4::1/64
!
router isis
 net 49.0000.0000.0001.00
 metric-style wide transition
 passive-interface Loopback0
!
router bgp 13
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 13
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 2001:0:1:4::4 remote-as 4
 neighbor 192.168.14.4 remote-as 4
 !
 address-family ipv4
  no synchronization
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 next-hop-self
  no neighbor 2001:0:1:4::4 activate
  neighbor 192.168.14.4 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-label
  neighbor 2001:0:1:4::4 activate
 exit-address-family

R2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
 ip router isis
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.23.2 255.255.255.0
 ip router isis
 speed auto
 duplex auto
 mpls ip
!
router isis
 net 49.0000.0000.0002.00
 metric-style wide transition
 passive-interface Loopback0
!
mpls ldp router-id Loopback0 force

R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.23.3 255.255.255.0
 ip router isis
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.35.3 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:3:5::3/64
!
router isis
 net 49.0000.0000.0003.00
 metric-style wide transition
 passive-interface Loopback0
!
router bgp 13
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 13
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2001:0:3:5::5 remote-as 5
 neighbor 192.168.35.5 remote-as 5
 !
 address-family ipv4
  no synchronization
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 next-hop-self
  no neighbor 2001:0:3:5::5 activate
  neighbor 192.168.35.5 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-label
  neighbor 2001:0:3:5::5 activate
 exit-address-family
!
mpls ldp router-id Loopback0 force

R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ipv6 address 2001:0:0:1::1/128
!
interface FastEthernet1/0
 ip address 192.168.14.4 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:1:4::4/64
!
router bgp 4
 bgp log-neighbor-changes
 neighbor 2001:0:1:4::1 remote-as 13
 neighbor 192.168.14.1 remote-as 13
 !
 address-family ipv4
  no synchronization
  network 4.4.4.4 mask 255.255.255.255
  no neighbor 2001:0:1:4::1 activate
  neighbor 192.168.14.1 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  network 2001:0:0:1::1/128
  neighbor 2001:0:1:4::1 activate
 exit-address-family

R5

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ipv6 address 2001:0:0:5::5/128
!
interface FastEthernet1/0
 ip address 192.168.35.5 255.255.255.0
 speed auto
 duplex auto
 ipv6 address 2001:0:3:5::5/64
!
router bgp 5
 bgp log-neighbor-changes
 neighbor 2001:0:3:5::3 remote-as 13
 neighbor 192.168.35.3 remote-as 13
 !
 address-family ipv4
  no synchronization
  network 5.5.5.5 mask 255.255.255.255
  no neighbor 2001:0:3:5::3 activate
  neighbor 192.168.35.3 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  network 2001:0:0:5::5/128
  neighbor 2001:0:3:5::3 activate
 exit-address-family

GNS File : http://www.4shared.com/rar/OOiHBwX0/IPv6_6PE.html

No comments:

Post a Comment