Sunday 11 August 2013

IPv6 Prefix Delegation

R1 Configuration

ipv6 unicast-routing
ipv6 dhcp pool test
!
ipv6 dhcp pool isp
 prefix-delegation pool cus
!
interface FastEthernet1/0
 ipv6 address FE80::1 link-local
 ipv6 address 2001:DB8:12::1/64
 ipv6 dhcp server isp
!
ipv6 local pool cus 2001:DB8:2::/49 56


R2 Configuration

ipv6 unicast-routing
!
interface FastEthernet1/0
 ipv6 address autoconfig default
 ipv6 enable
 ipv6 dhcp client pd from-isp
!
interface FastEthernet1/1
 ipv6 address from-isp ::1/64
 ipv6 enable


R3 Configuration

ipv6 unicast-routing
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 ipv6 address autoconfig default
 ipv6 enable


R1#show ipv6 route
S   2001:DB8:2::/56 [1/0]
     via FE80::C801:BFF:FE4C:1C, FastEthernet1/0
C   2001:DB8:12::/64 [0/0]
     via FastEthernet1/0, directly connected
L   2001:DB8:12::1/128 [0/0]
     via FastEthernet1/0, receive
L   FF00::/8 [0/0]
     via Null0, receive


R2#show ipv6 dhcp interface
FastEthernet1/0 is in client mode
  State is OPEN
  Renew will be sent in 3d11h
  List of known servers:
    Reachable via address: FE80::1
    DUID: 00030001CA000B4C0000
    Preference: 0
    Configuration parameters:
      IA PD: IA ID 0x00030001, T1 302400, T2 483840
        Prefix: 2001:DB8:2::/56
                preferred lifetime 604800, valid lifetime 2592000
                expires at Sep 10 2013 03:33 PM (2590703 seconds)
  Prefix name: from-isp
  Rapid-Commit: disabled


R3#show ipv6 route

S   ::/0 [2/0]
     via FE80::C801:BFF:FE4C:1D, FastEthernet1/0
C   2001:DB8:2::/64 [0/0]
     via FastEthernet1/0, directly connected
L   2001:DB8:2:0:C802:4FF:FED4:1C/128 [0/0]
     via FastEthernet1/0, receive
L   FF00::/8 [0/0]
     via Null0, receive

R3#ping 2001:db8:12::1
Sending 5, 100-byte ICMP Echos to 2001:DB8:12::1, timeout is 2 seconds:
!!!!!



Thursday 21 February 2013

6VPE_Inter-AS-6VPE


Task

To get the full connectivity between site 1,2 and 3.

Configuration

R1

vrf definition one
 rd 12:12
!
 address-family ipv6
 route-target import 3:3
 route-target import 12:12
 route-target export 12:12
 exit-address-family
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 vrf forwarding one
 no ip address
 speed auto
 duplex auto
 ipv6 address 2001:1:4::1/64
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 0
!
router bgp 12
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 12
 neighbor 2.2.2.2 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv6
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
 exit-address-family
 !
 address-family ipv6 vrf one
  no synchronization
  neighbor 2001:1:4::4 remote-as 4
  neighbor 2001:1:4::4 activate
 exit-address-family
!
mpls ldp router-id Loopback0 force

R2

vrf definition one
 rd 12:12
 !
 address-family ipv6
 route-target export 12:12
 route-target import 12:12
 route-target import 3:3
 exit-address-family
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.12.2 255.255.255.0
 speed auto
 duplex auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.23.2 255.255.255.0
 speed auto
 duplex auto
 mpls bgp forwarding
!
interface FastEthernet2/0
 vrf forwarding one
 no ip address
 duplex full
 ipv6 address 2001:2:5::2/64
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
!
router bgp 12
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 12
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 192.168.23.3 remote-as 3
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv6
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community both
  neighbor 1.1.1.1 next-hop-self
  neighbor 192.168.23.3 activate
  neighbor 192.168.23.3 send-community both
 exit-address-family
 !
 address-family ipv6 vrf one
  redistribute static
  no synchronization
 exit-address-family
!
ipv6 route vrf one 2001::5/128 2001:2:5::5
!
mpls ldp router-id Loopback0 force

R3

vrf definition one
 rd 3:3
 !
 address-family ipv6
 route-target export 3:3
 route-target import 3:3
 route-target import 12:12
 exit-address-family
!
ipv6 unicast-routing
!
interface FastEthernet1/0
 ip address 192.168.23.3 255.255.255.0
 speed auto
 duplex auto
 mpls bgp forwarding
!
interface FastEthernet1/1
 vrf forwarding one
 no ip address
 speed auto
 duplex auto
 ipv6 address 2001:3:6::3/64
!
router bgp 3
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.23.2 remote-as 12
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family vpnv6
  neighbor 192.168.23.2 activate
  neighbor 192.168.23.2 send-community both
 exit-address-family
 !
 address-family ipv6 vrf one
  redistribute static
  no synchronization
 exit-address-family
!
ipv6 route vrf one 2001::6/128 2001:3:6::6

R4

ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2001::4/128
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 ipv6 address 2001:1:4::4/64
!
router bgp 4
 bgp router-id 4.4.4.4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2001:1:4::1 remote-as 12
 !
 address-family ipv4
  no synchronization
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  no synchronization
  network 2001::4/128
  neighbor 2001:1:4::1 activate
 exit-address-family

R5

ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2001::5/128
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 ipv6 address 2001:2:5::5/64
!
ipv6 route ::/0 2001:2:5::2

R6

ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2001::6/128
!
interface FastEthernet1/0
 no ip address
 speed auto
 duplex auto
 ipv6 address 2001:3:6::6/64
!
ipv6 route ::/0 2001:3:6::3

Verification

R4#ping 2001::5 source loopback 0
Packet sent with a source address of 2001::4
!!!!!

R4#ping 2001::6 source loopback 0
Packet sent with a source address of 2001::4
!!!!!

GNS FILE : http://www.4shared.com/rar/Kg5avCct/6VPE_Inter-AS-6VPE.html